Loading...
首页 > 思科高级认证> 无线局域网认证 > 文档

思科Aironet1310多种虚拟局域网案例(MBSSID)

创建于: 2009-03-13 05:11:57          

 

虚拟局域网Vlans概述:

VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。

 

思科Aironet1310多种虚拟局域网案例(MBSSID)

下面描述了怎样在思科Aironet应用中,在各自的虚拟局域网中构建多种SSID。

 

构建多种SSID可以通过虚拟局域网1来实现,但是它可以轻易通过构建原始的虚拟局域网而被改变。这个原始的虚拟局域网是AP接入的三层交换机接口的虚拟局域网。否则,你需要一个新的在Fa0上的次级接口,然后连结这个次级接口和第一组,或者连接和次级接口有同样数字的组。

 

The following configuration demonstrate how to configure multiple SSIDs, each in their own VLAN, on a Cisco Aironet AP.

 

Management is achieved through VLAN 1, but could be easily changed by configuring the native VLAN of the switchport the AP is connected to to be in a different VLAN. Otherwise you'll need a new subinterface on Fa0, and bridge that to bridge group 1, or a bridge group by the same number as the subinterface.

 

This example has two SSIDs has no protection/encryption.

 

 

Cisco Aironet 1310 Configuration

 

 

ap#sh ver

Cisco IOS Software, C1310 Software (C1310-K9W7-M), Version 12.3(7)JA2, RELEASE S

OFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Fri 18-Nov-05 12:55 by ssearch

 

 

ROM: Bootstrap program is C1310 boot loader

BOOTLDR: C1310 Boot Loader (C1310-BOOT-M) Version 12.3(2)JA4, RELEASE SOFTWARE (

fc1)

 

 

ap uptime is 54 minutes

System returned to ROM by power-on

System image file is "flash:/c1310-k9w7-mx.123-7.JA2/c1310-k9w7-mx.123-7.JA2"

isco AIR-BR1310G-A-K9-R (PowerPCElvis) processor (revision A0) with 24566K/81

92K bytes of memory.

Processor board ID FOC10040BLK

PowerPCElvis CPU at 262Mhz, revision number 0x0950

Last reset from power-on

1 FastEthernet interface

1 802.11 Radio(s)

 

 

ap#sh run

Building configuration...

 

 

Current configuration : 2275 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

 

hostname ap

!

enable secret 5 $bEj7$XTYOY1jK0ahff9rltus6E/

 

ip subnet-zero

!

 

no aaa new-model

dot11 vlan-name dmz vlan 2

dot11 vlan-name inside vlan 1

!

dot11 ssid dmz

vlan fred

authentication open

authentication shared

mbssid guest-mode

 

dot11 ssid inside

vlan george

authentication open

authentication shared

mbssid guest-mode

!

 

!

username Cisco password 7 01300F175804

 

bridge irb

!

interface Dot11Radio0

no ip address

no ip route-cache

 

ssid dmz

!

ssid inside

 

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root access-point

cca 75

concatenation

infrastructure-client

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

 

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

full-duplex

 

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

 

 

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

 

interface BVI1

ip address 192.168.9.245 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.9.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

control-plane

 

bridge 1 route ip

!

 

!

line con 0

transport preferred all

transport output all

line vty 0 4

login local

transport preferred all

transport input all

transport output all

line vty 5 15

login

transport preferred all

transport input all

transport output all

 

end

ap#

 

 

Multi Layer Switch Configuration

 

 

Switch#sh ver

Cisco IOS Software, C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(46)SE

, RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 21-Aug-08 15:43 by nachen

Image text-base: 0x00003000, data-base: 0x01940000

 

 

ROM: Bootstrap program is C3750 boot loader

BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEC, RELEASE SOFTWAR

E (fc4)

 

 

Switch uptime is 49 minutes

System returned to ROM by power-on

System image file is "flash:/c3750-advipservicesk9-mz.122-46.SE/c3750-advipservi

cesk9-mz.122-46.SE.bin"

cisco WS-C3750-24TS (PowerPC405) processor (revision L0) with 118784K/12280K byt

es of memory.

Processor board ID CAT1004Z02Y

Last reset from power-on

2 Virtual Ethernet interfaces

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

 

 

Switch#sh run

Building configuration...

 

 

Current configuration : 1883 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

 

hostname Switch

!

boot-start-marker

boot-end-marker

 

!

no aaa new-model

switch 2 provision ws-c3750-24ts

system mtu routing 1500

vtp domain CISCO

vtp mode transparent

ip subnet-zero

ip routing

no ip dhcp use vrf connected

 

ip dhcp pool dmz

network 20.0.0.0 255.0.0.0

default-router 20.0.0.1

domain-name galileo.edu

!

 

!

 

!

 

!

 

!

 

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

 

vlan 2

!

 

interface FastEthernet2/0/1

!

interface FastEthernet2/0/2

 

interface FastEthernet2/0/3

!

interface FastEthernet2/0/4

 

interface FastEthernet2/0/5

!

interface FastEthernet2/0/6

 

interface FastEthernet2/0/7

!

interface FastEthernet2/0/8

switchport access vlan 2

switchport mode access

 

interface FastEthernet2/0/9

!

interface FastEthernet2/0/10

 

interface FastEthernet2/0/11

!

interface FastEthernet2/0/12

 

interface FastEthernet2/0/13

!

interface FastEthernet2/0/14

 

interface FastEthernet2/0/15

!

interface FastEthernet2/0/16

 

interface FastEthernet2/0/17

!

interface FastEthernet2/0/18

 

interface FastEthernet2/0/19

!

interface FastEthernet2/0/20

 

interface FastEthernet2/0/21

!

interface FastEthernet2/0/22

 

interface FastEthernet2/0/23

!

interface FastEthernet2/0/24

description link to the Cisco Aironet 1310

switchport trunk encapsulation dot1q

switchport mode trunk

 

interface GigabitEthernet2/0/1

!

interface GigabitEthernet2/0/2

 

 

 

interface Vlan1

ip address dhcp

!

interface Vlan2

ip address 20.0.0.1 255.0.0.0

 

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.9.1 254

ip http server

ip http secure-server

!

 

control-plane

!

 

line con 0

line vty 5 15

!

end

 

 

Switch#

 

 

Luis E. Ochaeta

 

 

评论 (0)